
1.0 Getting started

This product is a WordPress Theme. This means that you need a valid and updated installation
of WordPress to get started. As this manual regards only the the Theme product itself, if you
are new to WordPress, you can find useful information in the official WordPress Codex:

Installing WordPress [http://codex.wordpress.org/Installing_WordPress] 
If your hosting provides Softaculous or Installatron, you can easily install WordPress
from your Cpanel.
First steps with WordPress [http://codex.wordpress.org/First_Steps_With_WordPress]
WordPress FAQs [http://codex.wordpress.org/FAQ_New_To_WordPress]
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1.1 Requirements

This theme requires the following:

WordPress 4.7 or higher
MySql 5.6 or higher
PHP 5.6 or higher

The theme also requires the following PHP libraries for an optimal performance:

CURL enabled
.htaccess
ModRewrite ON
upload_max_filesize: 128M (to support upload of Podcasts in mp3)
memory_limit: 128M
post_max_size: 128M (to support upload of Podcasts in mp3)
max_execution_time: 240 seconds

How to verify your server limits: please use this plugin
https://wordpress.org/plugins/wordpress-php-info/.

 

If you see an error “Are you sure you want to do
this”

or other memory or upload limit errors during the upload, please use one of these solutions
(any server is different so one of these methods may work better than the others depending
on the server settings)

1. add this in the .htaccess file of your server 

php_value memory_limit 128M 

php_value post_max_size 128M 

php_value upload_max_filesize 128M 

php_value max_execution_time 1800
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2. add thiss to wp-config.php 

define(‘WP_MEMORY_LIMIT’, ’64M’);

3. create a text file, call it php.ini and put this text in it: 

upload_max_filesize = 64M 

post_max_size = 64M

then upload it in the wordpress root folder

 



1.2 Support

This theme comes with 6 months of support and free updates. After 6 months you can extend
the support coverage.

For more details about the official Envato support policy please check the document
at:  http://themeforest.net/page/item_support_policy

And more details here: SUPPORT POLICY

To provide support in the most efficient way, we provide an online Helpdesk forum, where you
need to register in order to post your requests. We use a forum in order to:

1. Track the requests and answers in an efficient way
2. Create a base of knowledge that can be easily indexed and accessed by other users

Support de�nition:

The support doesn’t cover code customizations or support on third party plugins, issues
caused by conflicts with other plugins or basic WordPress questions, which have to be
addresses using the official WordPress codex knowledge base.

Installation service for WordPress, themes or plugins is not part of the support and is not
provided by us.

We can help with settings and questions not enlightened in this manual, or minor design
changes,  for any other need we recommend to hire a developer. The support service
doesn’t generally cover any request that requires to edit the theme’s or plugin’s core
files, unless you encounter any bug which we will fix as soon as possible.

 

How to get support:

1. Get your Themeforest purchase code ( http://themeforest.net/downloads -> Download
License Certificate & Purchase Code ).
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2. Sign up to our Helpdesk using your Purchase Code and Envato Username obtained before

3. Please read the manual before creating a ticket for topics already covered here.

4. Use the search engine of the Helpdesk to find similar topics: most of the times each new
request has been already covered by other customers, so you may find your answer in a much
shorter time.

5. If you don’t find any answer, open your ticket here.

 

http://www.themes2go.xyz/helpdesk/register/
http://www.qantumthemes.com/helpdesk/forums/forum/onair2-theme-support/


1.3 Theme Installation

You can install your new theme in the following ways:

1. From the admin dashboard, using the WordPress theme installer (easiest method).
2. or manually via FTP

Please make sure that you start from a fresh WordPress installation, without any content or
plugin(s). Once the theme is installed, you can import your content from other sources.

IMPORTANT NOTE BEFORE INSTALLING THE THEME:

This theme provides a child theme, making it easier to update your site with new theme
versions without losing any customizations or settings. The following instructions will teach
you how to correctly install and activate the theme using the child theme, which will
make your life much easier down the line:

Automatic theme installation from the
WordPress Admin

1. Login to your WordPress admin panel this will usually be your wordpress site/domain
name followed by   /wp-admin

2. Go to Appearance > Themes
3. Click Install Themes and then Upload
4. Click on the “Browse” button and select the zipped folder of the theme from your

computer.
5. Upload the theme called lifecoach.zip but DO NOT ACTIVATE IT
6. Once done click on “Return to themes”
7. Also upload the theme lifecoach-child.zip, and ACTIVATE lifecoach-child.zip
8. Make sure you upload the theme zip file and not the product zip file.
9. An alert at the top of the page will ask you to install the plugins required to use all the

functions of the theme. Select them all and select “install”.
10. Wait until the process has finished.
11. Some plugins are not strictly required, as the QT LoveIt and QT Ajax Page Loader, you’ll

need to select them and choose “activate” after the installation of step 10.

Troubleshooting:
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Troubleshooting:

Error: The theme is missing the style.css stylesheet

If you see this error, it means that you are trying to upload the entire product package instead
of the correct theme zip file. Please unzip the product folder in your computer and upload only
the theme zip file and the child theme’s zip file.

NOTE: If you are installing the theme with the automatic installer and you get an error
message “Are You Sure You Want To Do This?” this means that your server configuration
doesn’t allow the upload of the file due to its size. We can work around this by uploading the
theme via FTP. 
In alternative, try the following solution:

MEMORY LIMIT FIX:

If you get problems related to memory whilst importing the demo content, edit your wp-
config.php in the root of your WordPress website, by adding these lines of code: 

define( 'WP_MAX_MEMORY_LIMIT', '256M' );

If you still have trouble, please refer to the official guide here:
http://codex.wordpress.org/Common_WordPress_Errors#Maximum_execution_time_exceeded

Manual theme installation (FTP
installation)

1. Download the zipped theme folder and extract it on your local PC.
2. Make sure you unzip the correct theme folders (lifecoach.zip and lifecoach-

child.zip), the one that contains the style.css and index.php files. Make sure that you
are not uploading the “product” folder. If the folder that you are going to upload
contains some zipped files, it is not the correct one.

3. Connect to your hosting provider using an FTP client (e.g. Filezilla is one of the best free
FTP clients, you can get it here)

4. Navigate to your WordPress installation folder (usually is not the root folder but it
should be public_html, www or something else, depending on your hosting provider
settings).To be sure that you are in the WordPress folder, you should see the following
three folders inside: 
– wp-content 
– wp-admin 
– wp-includes

5. Navigate to wp-content/themes
6. Upload the two theme folders you already unzipped (see step 2. above): lifecoach and

lifecoach-child to the wp-content/themes folder.

http://codex.wordpress.org/Common_WordPress_Errors#Maximum_execution_time_exceeded
https://filezilla-project.org/download.php


7. On your browser navigate to the admin dashboard of your wordpress site (usually
yoursite.com/wp-admin)

8. Go to Appearance-> themes and activate: LifeCoach Child

Installing the required plugins:

An alert at the top of the page will ask you to install the plugins required to use all the
functions of the theme. Select them all and select “install”.
Wait until the process has finished.

Please follow the next manual chapter to install the demo contents.



1.4 Required plugins installation

This theme features special functions like custom post types and custom post meta fields.
To add such functions, you need to install all the required plugins.

How to install the required plugins:

There are 3 ways:

1. Recommended Method: After installing the theme, a message will be prompted at the
top of the screen. Follow the instructions, select all the plugins and select “install”.

2. Manual Upload Method: (in case of problems with the original method): Unzip the
theme folder on your computer and dig in the subfolder named TGM-Plugin-
Activation/plugins and install them one by going in Wp Admin->Plugins->Add New-
>Upload

3. FTP Method: (in case of problems with the manual upload and automatic installation):
Unzip the theme folder on your computer and dig in the subfolder named TGM-Plugin-
Activation/plugins , unzip all the plugins and upload them in wp-content/plugins,
then go in Wp Admin->Plugins, select them all and activate them.
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1.5 Plugins updates

Bundled plugins update

When you update the theme, go in Plugins. If any plugin needs an update  you’ll see a notice at
the top of the page. Just follow the instruction for the automatic procedure.

To update Visual Composer:

Visual composer can’t be updated automatically because of plugin’s restrictions. Please follow
these steps:

1. Unzip latest theme version
2. In the unipped theme’s folder look for TGM-Plugin-Activation/plugins
3. Unzip js_composer.zip
4. Via FTP upload it in wp-content/plugins replacing the old version

Premium plugins update:

The theme may provide bundled plugins such as Visual Composer or others. Due to Envato’s
licensing rules, we provide the plugins as a built-in feature provided under a Bundle extended
license, which forbids us to provide License Certificate and Purchase Code to our customers.

We can provide plugin’s updates only when we provide a new version of the theme. This
because we need to test the new plugin versions with the theme and be sure that everything
works well together before distributing theme.

It will be our duty to provide fast updates in case security issues or severe WordPress
incompatibilities appears.

If you see any message asking to provide a purchase code of the bundled plugins, you
can discard it or purchase a Personal License on Codecanyon.net, but we can’t ensure
that updated versions will work smoothly with our theme as the one we provide, as is
not yet tested with the theme.
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1.6 Customizing your website

This theme is customizable using the standard WordPress theme customizer function.

You can access to the customizer visiting Appearance->Customize.

Here you can find all the list of available style customizations.
For options not contained in the list, you may need to hire a
developer.

The support service doesn’t provide CSS, PHP, JS or HTML
code customization, as this service is out of the Theme’s

Support service (such as when you buy a car, adding a new soundsystem is not part of the car
assistance service).

 

 

 Available customization settings:
 

Site identity

Here you can change site title, tagline (not used by the theme) and the FavIcon.

Colors customization

This theme is based on a Material Design Framework:

this means that a same color is applied to multiple elements, and sometimes is not possible to
assign a specific color to a specific elements without changing other parts of the site. 
This is called a color pattern, and this is the standard way Material Design works, to
maintain a harmony between the elements and provide a consistenT color pattern.
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Be sure to choose high contrast
colors between page background and
text color. Accent and secondary
colors must always be bright colors
that can be seen both on black and on
white.

The text on primary, accent and
secondary colors is always white and
can’t be changed.

To create negative patterns you can
choose dark colors for Page and Paper,
and a light color for the text.

You can calculate cool color palettes on
websites like:

http://paletton.com/
https://coolors.co/browser

If you want to change the color of a
specific element indipendently from the
framework, or to change the color of
elements not customizable by the
customizer, you may need to add your
own custom CSS.

You can add it in the styles.css file of the
Child theme folder in wp-
content/themes/lifecoach-
child/styles.css

To edit the CSS file you may also use the
function in Appearance->Editor.

Please note that these advanced
customizations are generally beyond the
normal product support boundaries.

Performance and SEO tips:

To provide the customized colors, the theme adds some custom CSS in the Header of the
HTML. 

http://www.qantumthemes.com/helpdesk/2016/10/25/code-customizations/


It is not much, but to improve the SEO score of a site, you may want to change this behaveior.

To do so, you can proceed as folow:

1. Complete your color and settings customizations in the theme’s customizer
2. Copy the custom styles from the header of the HTML and put it in the styles.css of the

child theme
3. In the functions.php of your child theme, create an empty function called

qantumthemes_css_customizations which will prevent the theme from outputting
the custom CSS.

 

Social Networks

Add your social network icons in footer and header. Available social icons:

Twitter username
Beatport
Amazon
Facebook
Blogger
Behance
Bebo
Flickr
Pinterest
RSS
Triplevision
Tumblr
Twitter
Vimeo
WordPress
Whatpeopleplay
Youtube
Instagram
Soundcloud
Myspace
Googleplus
Itunes
Juno
Lastfm
Linkedin
Mixcloud
Resident-advisor



Reverbnation

Menus

This theme features 2 menu locations:

1. Header menu: supports 3 levels of depth 
2. Footer menu: supports 1 level of depth

To customize your menus go in Appearance->Menu

Full official tutorial: https://codex.wordpress.org/WordPress_Menu_User_Guide

 

Header customization

https://codex.wordpress.org/WordPress_Menu_User_Guide


Logo (any width, 100px height). The height of the logo or the menu bar cannot be
changed.
Default header image (if is not a single page or there is not featured image for the
single page/post)
Header size: fullscreen or normal
Transparency: if enabled, the menu will ahve tranparent background and become
opaque on scroll
Search button: adds search functionality to the header



Typography (Google Fonts)

You can set 4 font families and variants for:



Baisc font [Family, Variant, Subset, Font size]
Bold font [used for the STRONG tag]
Headings  [Family, Variant, Letter Spacing, Text Transform]
Menu [Family, Variant, Letter Spacing, Font Size, Text Transform]

404 Error page

Define a background for error pages

 

Sidebars customization

You can choose, for the single page of any post type, if you want or not the sidebar:



Footer customizations



Footer text: supports HTML basic tags like <a> or <br>
Widgets background picture
Footer logo
Hide/show footer widgets

 

Events settings



Events are ordered by event date. To automatically hide the past events you have to set on Yes
this option.

To show separately past and upcoming events, you have to create 2 Event Types and link them
separately from the menu.

Widgets

Please always go in Appearance->Widgets to organize the widgets, as from customizer you
won’t see the sidebars if they are not in your current page.

The footer uses Masonry to divide the widget in columns.

Static front page:

If you set “Latest posts” the index.php template file will be used, which is a blog template.

Otherwise you can choose any page from the previously created pages.

Is not necessary to set manually a Posts page, as you can create a normal page and
choose a specific blog template with more options. If you set a blog page as Posts page
in reading settings, some design settings may be ignored as WordPress doesn’t
recognize it as page.

Additional CSS

You can add here your custom CSS. For a better performance, please add it to the styles.css of
your child theme by going in Appearance->Editor.

Developer settings



If you are facing javascript issues or you want to load the separate javascript files instead of a
unique minified script, enable the developer settings. 
This will increase the size of the website for the users and provide a worst performance, so
never leave it enabled for production websites. Is just to help you debugging functionsl issues
you may face for plugins conflicts or bad settings of the shortcodes.

 



1.7 How to update the theme

Automatic theme update:

1. Be sure to have the Envato Market plugin installed
2. Click on Envato Market on the left column and follow the instructions for obtaining your

API key
3. Once you add the API key in the settings page, you can update your theme from the

main Envato Market page

Automatic plugins update:

After updating the theme, visit the Plugins section. 
An alert on the top of the page will invite you to update the plugins, and you just have to follow
the procedure.

Visual composer update:

Visual composer can’t be updated automatically unless you don’t purchase a Personal License,
as it comes in Bundle. 
To update this plugin, you have to:

1. Unzip the theme folder on your computer
2. Navigate to TGM-Plugin-Activation/plugins
3. Unzip the file js-composer.zip
4. Via FTP navigate in your site to the folder wp-content/plugins
5. Upload the unzipped folcer js-composer replacing the old one.

Child theme update:

The child theme doesn’t need to be updated. More info

Manual Update:

You can download new updates from Themeforest.net/downloads for as long as the
product is maintained
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A full file and database backup is recommended before updating. 
No pages or site contents are deleted when updating themes or plugins. 
If you used the child theme, just replace the main theme file and leave the child theme intact.

1. Unzip the theme folder on your local computer (for example on the desktop) 
2. Backup your old theme version located in wp-content/themes/lifecoach 
3. Upload the theme via FTP replacing the old theme folder in wp-content/themes 
4. In your local theme folder, after unzipping, navigate to TGM-Plugin-Activation/plugins 
5. Unzip all the plugins and upload them to the wp-content/plugins folder, replacing the
old ones 
6. visit the ADMIN screen and verify if you need to install any missing plugin(s). If you are
updating from very old versions

ALTERNATIVELY:

1. After the theme update go in the Plugins page
2. Follow the instructions prompted at the top of the page

Important:

Each update version contains the list of changes in lifecoach/changelog.txt. Before
updating always check what’s new, as some big updates may require additional actions
to be isntalled.



1.8 Demo Contents 

IMPORTANT: Do not run this procedure on websites that contains already articles and
contents, as they will be rewritten. If you have a pre-existing website, create a new site and
run the demo setup on the new site, then import your old contents in the new website.

To make your life easier, instead of providing only the .xml, we provide a One Click demo
installation plugin.

You can find the demo installation plugin in the product folder, under the Demo Content
Installer folder

These plugin will setup the entire site as in the demo, except for 2 details:

1. The menu
2. The media contents (which can’t be distributed for royalty reasons)

Before proceeding, be sure that you DON’T HAVE ALREADY INSTALLED the classic
WordPress importer plugin, as it is already included in the One Click installation plugin.

Be sure to be using the child theme and not the parent theme in Appearance->Themes:

Step 1: To install the demo content, go in

Plugins -> Install new -> Upload Plugin

Step 2: Select the One Click demo installer plugin provided in the product folder

Step 3: Install the plugin and activate it.

Step 4: Return to the Dashboard

Step 5: You will find a new item under Appearance: click Installer Panel

Step 6: Carefully READ the instructions you will see there

Most Viewed Article
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Step 7: Be sure you are not running the installer over pre-existing contents: they will be
deleted or modified!

Step 8: Click “Run Installer” and wait till a confirmation text appear. Don’t run the
procedure twice.

Step 10: Go in Appearance->Menu->Manage locations and set the menus in the proper
locations

All done!

Check your website, all the contents and structure will be there. Of course the images will be
replaced with a default image for royalty reasons.

PS. do you want only the xml? Unzip the plugin, it is inside of the Demo subfolder.



2.0 Creating contents

Custom post types:

This theme features 7 Custom Post types. The post types are added by specific plugins, as per
WordPress development rules. This means that you won’t see any of these post types
unless you install the required plugins as explained in the plugins installation section.

Post types added by Theme Core plugin:

The Theme Core plugin (ttg-core) is responsible for generating all the extra functions of the
theme, such as customizer and extra fields or post types. If you don’t see the custom types,
visit your plugins folder and activate it.

Team members:  for music bands or members of a company or crew.
Podcast: allows to add Podcasts with MP3, Mixcloud, Soundcloud or Youtube player.
Events: allows to add Events with a date, a map and a countdown. Events can be added
to an events map via the QT Places Plugin (included with the theme).
Sponsors: creates a scrolling footer of sponsors, which you can activate for single
pages
Testimonials

DEVELOPERS INFO: All the custom types, taxonomies and shortcodes declarations are in the
theme’s subfolder “/ttgcore-setup/custom-types/”. 

Places:
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Places:

Added by QT Places plugin, allows to create Places and to create maps with locations
and filters. 
Please note this is a premium plugin bundled with the theme. You need a personal
license to receive support. 
Plugin page: https://codecanyon.net/item/qt-places-interactive-responsive-google-
maps-wordpress-plugin/15674168
The PDF manual is included in the LifeCoach product folder

Videos

Created by QT Videolove Plugin. Allows to add videos and display a gallery of
filterable videos using the [videolove] shortcode. Please visit Settings->Videolove for
usage instructions.

https://codecanyon.net/item/qt-places-interactive-responsive-google-maps-wordpress-plugin/15674168


2.0.1 Author header and thumbnail

You can add a thumbnail and a featured image for every author. These pictures need to be
uploaded in the media archive of WordPress.

1. Go in Media->Add new 

2. Upload a squared thumbnail 250×250 and a fullscreen image 2500px width
3. Go in edit for the single files to obtain the media URL 

4. Copy the Url, then go in Users and edit the user who needs the picture, pasting the
picture URL in the required fields: 
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2.0.1 Page design customization

Every page that you build going in Pages->Add new has few design customizations, which can
override the global settings of the Customizer.

You can use the checkboxes to hide menu, header, widgets in the footer, or even the footer
bar, till obtaining a total empty template to craft a totally unique page.

You can also override the header transparency, or set it to Default to take the Customizer
global settings.

By default this theme has also Fullscreen headers in the desktop version. you can change the
header size in the customizer or set a custom size fo a specific page.

To change these settings, while editing a single page, scroll below the text editor to find
the following customization panel. 
Remember that you need to save the page to see these changes, as the preview will not
apply the changes made at these parameters.
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2.0.3 Contacts Page

This theme allows you to easily create a contacts page including a contact form, contact details
and a Google map.
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1. be sure that the QT Contacts plugin is installed
2. create a new page and choose the Contacts page template
3. save, a  new tab of settings will appear below the content editor (contact details)
4. Fill in all the contact details
5. The  contact module will appear in the page

All the editor contents will be displayed above the form, allowing you to create more contents
in the same page.



2.1 Creating pages with Visual Composer

Go to Page->Add new

Choose Page Visual Composer as page template in the right column

Enter a title

Save or publish
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Click Backend Editor

Start adding elements: click the + button and add first a Row, then your desired elements.

Please never put the custom elements from the LifeCoach slideshows and carousels in
multi-column rows, always put them in a full-width row.

 

Custom functions for layout:

In the Row settings you can set a row as negative (texts will use the background colors,
useful for sections with background photos) and you can add a container, as this template is
100% width.



In Theme Shortcodes you have a huge number of custom elements added by this theme. Their
equivalent shortcode and parameters are discussed in the Theme Shortcodes section of the
manual.

Of�cial manual for Visual Composer:

https://wpbakery.atlassian.net/wiki/display/VC/Visual+Composer+Pagebuilder+for+WordPress

Please note we DO NOT provide Visual Composer support with the Bundle License. You need a
Standard License for Visual Composer if you need extra support with this product (click here to
buy a Standard license).

Visual Composer updates

If you see plugin update notices, we will provide a theme update as soon as possible
with the latest plugin version. You cannot have a purchase code with the bundled
version, nor update the plugin yourself. Please note that the plugin version we
distribute is tested and working with our theme, while a more updated version may
have issues as is not tested with our products.

https://wpbakery.atlassian.net/wiki/display/VC/Visual+Composer+Pagebuilder+for+WordPress
https://codecanyon.net/item/visual-composer-page-builder-for-wordpress/242431?rel=WordpressThemes2Go


2.2 Team members

1. Click Team members
2. Click Add new team members

3. Enter a title and description
4. Add Short bio, role, social profiles

5. Add a Featured image. This will be the member’s profile photo (for best results we
suggest to upload files by 2550px width)
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6. Select one or more team member types, they are like categories, but for members. 
You can also create archives for specific event types.

7. Click “Publish” or “Update”

Creating the events archive:

1. Go to pages->Add New

2. Select the Archive Members template



3. In Appearance->Menus link to the page you just created (optional)



2.3 Sponsors

1. Click Sponsors
2. Click Add New

3. Enter a title and description
4. If needed, add a link url

5. Add a featured image. This will be the sponsor’s image featured in the sponsor
carousel.

6. You can order the listed sponsor by setting a value in Post attributes tab.

7. Click “Publish” or “Update”

Creating the Sponsor carousel

1. Go to Pages or Posts->Add New

2. Click on Visual Composer’s Backend Editor button.
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3. Click on Add element

4. Choose Sponsor carousel. 
 

5. Customize its settings

6. Click Save changes





2.4 Testimonials

1. Click Sponsors
2. Click Add New

3. Enter a title and description
4. Add the testimonial author

5. Add a featured image. This will be the testimonial’s profile image.
6. You can select a category to every testimonial by simply checking or writing a new one

in Testimonial Category tab

7. You can order the listed sponsor by setting a value in Post attributes tab.
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8. Click “Publish” or “Update”

Creating the Podcast archive:

1. Go to pages->Add New

2. Select the Archive Testimonials template

3. In Appearance->Menus link to the page you just created (optional)



2.5 Events

1. Click Events
2. Click Add New

3. Enter a title and description
4. Choose a date using the datepicker. Date format must be YYYY-MM-DD (Year month

date)

The event countdown appears for future events and is hidden for past events.

5. Insert an address and any other details
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6. If you want to show a google map for the event, insert the location of the event and
click “Geolocate Address”

7. Add a website URL for the event
8. Add a location name, like “NY Conference Hall”
9. Add a contact phone number

10. Add a external event link
11. Add as many links to buy the ticket as you want
12. Select one or more event types, they are like categories, but for events. You can also

create archives for specific event types.

13. Click “Publish” or “Update”

Creating the events archive:

1. Go to pages->Add New

2. Select the Archive Events template



3. In Appearance->Menus link to the page you just created (optional)

Important!

You can hide or show the events depending on the event date. To change this option go to 
Appearance->Customize->Events.

Creating an event map:

1. Be sure to have the QT Places plugin installed and active
2. Be sure that you are not hiding past events in case that you want to show them
3. Add the shortcode [qtplaces posttype=”event”].
4. See the QtPlaces documentation for more infos
5. You can also use the QtPlaces shortcode generator in your page editor
6. Check the page Settings -> QT Places for more infos
7. Don’t use the Google Maps API unless necessary and unless you know how to

properly generate it (check Google’s documentation about this. Only needed for sites >
20K visitors a day)



2.6 Podcast

How to create a new podcast page

1. Click “Podcast” > “add new”

2. Enter the title and a description
3. Add an Artist name and a date

4. Add the podcast link (this can be a link from mixcloud, soundcloud, youtube or a simple
mp3)

5. Upload a featured image (we suggest images of 2550x2550px; consider to compress
your image before uploading for better performance)

6. Suggested: insert some “Podcast filters”, those will be the labels with which you can
filter podcasts in the podcasts archive pages.
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Creating the Podcast archive:

1. Go to pages->Add New

2. Select the Archive Podcast template

3. In Appearance->Menus link to the page you just created (optional)



2.8 Archive pages

This theme features special page templates to create the archives. To create an archive page:

1. go to Pages->Add New

2. Choose the Archive template under the Page Attributes:

Each archive has its own template: we selected for each “post type” the best visualization. The
specific post types can be displayed only through each specific template.

The template used to display a specific post type, can’t generally be used for another.

The available archive templates are:

1. Events
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2. Members
3. Podcast
4. Testimonials
5. Videos
6. Blog Cards
7. Blog No Sidebar
8. Blog Sidebar

The amount of items per page is fixed for each post type, to match with the best standards of
design and performance. 
The amounts of items per page is defined in the file functions.php

If you add any content to the archive page, it will only be visible in the first page of the
archive. You can also add slideshows or other elements using the Visual Composer, to make
your archive page more attractive.

Once you created an archive page, you can add it to a menu in Appearance->Menu.



3.0 Theme Shortcodes

This thee provides a series of shortcodes to display sliders, carousels or other elements.

You can use the shortcodes in the classic way, or you can use Visual Composer where every
shortcode has its own Drag ‘n Drop item.

Important: the following items needs to stay in a 12
columns row (do not put them in multi column- rows)

Post Carousel
Featured Event
Hero Box
Post Hero
Slideshow
post Grid
Testimonial Slideshow
Event Slideshoe
Sponsor Carousel

This is a list of shortcodes and parameters:

Hero Box
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The hero box creates super bold texts via shortcodes. The content will be the heading of your
page as is wrapped into an H1 tag, perfect for SEO optimization. 

How to create a hero box:

Add a new element and choose Hero Box

Click on the tiny arrow to edit the text



Click the + button to add more rows, you can specify the size of each row with the dropdown
menu:

Hero list



Hero list

 

Buttons



Add buttons stiled with the theme’s design. You can choose style, size, text, link and alignment.

 

Captions: there are 3 captions format, small,



Captions: there are 3 captions format, small,
medium and large

Caption large

Centered huge caption for a section.

[qt-caption-large title=”Section Title” class=”YourExtraClassCss”]

 

Caption Medium

Centered huge caption for a section.



[qt-caption-med title=”Section Title” class=”YourExtraClassCss”]

Caption Small

Left aligned caption, smaller.

[qt-caption-small title=”Section Title” class=”YourExtraClassCss”]

Spacer

Adds a vertical spacing (responsive) to avoid using Visual Composer spaging and maintain the
original theme’s vertical rhythm.

[qt-spacer size=”m”]

size: it can be s, m or l, which stands for small, medium or large.

Featured event

This shortcode allows to display a specific event or the first event occurring by event date.
Allows to display also a countdown.





 

[qt-event-featured id=”” label=”” countdown=””]

id: specify the ID of an event or leave blank for the first upcoming

label: text of the header for the featured event

countdown: set to 1 to display a countdown

 

Events Carousel

To create an events carousel, choose Post Carousel, and select the post type “Event”. The items
will be ordered by event date, and past events will behidden.



 

Events Slideshow

 



 



You can filter events by Eventtype Slug, which you can find going in the posttype list and
clicking “quick edit” on your chosen term.

 

Post grid

Displays a grid of posts in 4 columns with title below the picture.

[qt-post-grid category=”” quantity=””]

category: specify a category slug to filter posts (Not the ID, the SLUG!)

quantity: number, use multiples of 4

Post hero



Displays a huge post banner with background image and excerpt.

[qt-post-hero category=”” quantity=””]

id: display a single post with this numeric ID

category: specify a category slug to filter posts (Not the ID, the SLUG!)

quantity: number

Post Carousel

Display a carousel of posts. You can use any post type, the layout of the elements will be
chosen correspondly. Only the post types of this theme are supported.

For any posttype, you can specify a category filter of the corresponding post type.

To find the slug, visit the list of the categories, and “quick edit” the selected category to reveal
the slug.



 

[qt-slideshow-carousel category=”” quantity=””]

category: specify a category slug to filter posts (Not the ID, the SLUG!)

quantity: number, use multiples of 4

Post Slideshow



Display a slideshow of posts.

[qt-slideshow category=”” quantity=””]

category: specify a category slug to filter posts (Not the ID, the SLUG!)

quantity: number, use multiples of 4

 

Sponsors carousel

Displays a list of sliding sponsors. You can choose the amount of items per row, 4 or 6, and the
number will adapt for mobile devices (3 for tablets, 1 for mobile phones) 



 

 

Video Galleries

The videos added with the Video post type can be displayed in a filterable gallery.

To customize the styling of the gallery such as colors and spacings, you can go in Settings-
>VideoLove. 
the font size of the titles is handled by the theme’s styling.



 

Team Carousel, Podcast Carousel, Events
Carousel and Testimonial Carousel:



Choose the post Carousel element, and set the required post type:

Icons

This theme bundles the Icons2go premium plugin. The manual is included in the them’s
product folder.

https://codecanyon.net/item/icons2go-icon-font-wordpress-plugin/19583567


 



4.0 Translating the theme

This theme is very easy to translate as the .mo .po (pot) files are provided within the language
sub folder of the theme.

In the main theme folder in wp-content/themes/lifecoach you’ll find a “languages” folder.

It contains a model to translate the theme using Poedit or other .mo .po translation softwares. 
1. Start up Poedit.

2. In Poedit goto File -> New from POT/PO file…

3. Select and Open the pot file from the languages folder.

4. Enter your name, email address, your language and country (i.e. French fr_FR, German
de_DE) to the setting form.

5. Click the Update button in the main Poedit UI.

6. Save the file: 
– For a plugin like filename-xx_XX.po with xx_XX for your language and country. 
– For a theme xx_XX.po

7. In WordPress Admin,  settings -> general set the language of your country.

8. That’s it, go to your WordPress blog and see your translation in action. N’joy your blogging!!!

Please remember to create the translation file of the plugin Theme Core. Its .pot file is in

wp-content/plugins/ttg-core/languages

– Save it as ttg-core-xx_XX.po with xx_XX for your language and country.

For more information please visit: https://codex.wordpress.org/Translating_WordPress

You can download Poedit here:
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Copyright informations

Javascript Libraries

jQuery 
https://jquery.org/license/
MaterializeCSS framework 
Materialize v0.97.5 (http://materializecss.com) 
Copyright 2014-2015 Materialize 
MIT License (https://raw.githubusercontent.com/Dogfalo/materialize/master/LICENSE)
Kirki options framework 
https://github.com/aristath/kirki 
License: GPLv2 or later 
License URI: http://www.gnu.org/licenses/gpl-2.0.html
VelocityJS.org 
VelocityJS.org (1.2.3). (C) 2014 Julian Shapiro. MIT @license:
en.wikipedia.org/wiki/MIT_License
Animator.js 1.1.9 
This library is released under the BSD license: 
Copyright (c) 2006, Bernard Sumption. All rights reserved.
Classie.js 
Classie.js 
https://github.com/yawetse/classie/blob/master/classie.min.js.map
FlipClockJs 
FlipClockJs 
http://flipclockjs.com/
Swipebox 
Swipebox v1.2.9 | Constantin Saguin csag.co | MIT License |
github.com/brutaldesign/swipebox */
jQuery Cookie Plugin v1.3 
https://github.com/carhartl/jquery-cookie
jQuery Easing v1.3
http://gsgd.co.uk/sandbox/jquery/easing/ 
Open source under the BSD License.
Owl carousel 
@version 2.0.0 
@author Bartosz Wojciechowski
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Particles.js 
Author : Vincent Garreau – vincentgarreau.com 
MIT license: http://opensource.org/licenses/MIT
prettySocial.js 
jQuery prettySocial: Use custom social share buttons 
Author: Sonny T. <hi@sonnyt.com>, sonnyt.com
SoundManager 2: JavaScript Sound for the Web 
http://schillmania.com/projects/soundmanager2/ 
Copyright (c) 2007, Scott Schiller. All rights reserved. 
Code provided under the BSD License: 
http://schillmania.com/projects/soundmanager2/license.txt

 

Photos

https://unsplash.com/
https://stocksnap.io/
https://bootstrapbay.com/blog/free-stock-photos/
http://www.gratisography.com/
http://negativespace.co/
http://splitshire.com/
http://littlevisuals.co/
http://www.lifeofpix.com/
http://deathtothestockphoto.com/
http://superfamous.com/
https://picjumbo.com/
http://www.imcreator.com/free
http://nos.twnsnd.co/
http://getrefe.tumblr.com/
http://freestocks.org/

Photos are not included in the product
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